Моторколесо Xiaomi Mijia M365

#колеса
#мотор
+
Открыть шапку темы
Alberto
Участник
Rating: 12
Alberto
03 may 2019, 0:59
Posted: 03 may 2019, 0:59
[quote="M365 spain"]350Вт, 23S 100V .. мотор почти не греется[/quote]

Поздравляю с завершением) 


Тоже заканчил историю с внедрением статора и магнитов от гироскутера. Была изначально идея поставить статор как есть, но меня удручало низкое качество намотки провода. Пока ждал ротор с расточки, решил все же перемотать статор на 10 витков по 7 жил. Влезло, но очень - очень плотно. Расточка - 2000 руб. (можно найти дешевле, но я не заморачивался)

Родные магниты отвалились очень легко, отщелкивались один за другим кухонным ножом без подготовки вообще. если кому нужно 29 магнитов  (1 поломался, т.к. я не очень старался быть аккуратным) от оригинального колеса, велкам) Новые магниты наклеил температуростойким эпоксидным клеем.

Ось статора легко выдавливается и устанавливается сьемником подшипников за 200 руб из магазина запчастей. 

Я видимо, мотор перегревал несколько раз, так как штатный статор довольно резко пахнет горелым лаком, хотя видимых повреждений небыло, и на ходу было все ок. Но 950 вт для штатного колеса лучше не выставлять.  Датчики холла тоже поставил оригинальные, так как они тоже не были приклеены вообще (держались на проводах)  и я их просто вынул. 


На холостом ходу на 42 v приложение показало макс. 38 км/ч. Посмотрим, какой будет результат на ходу..


А вообще больше такое повторять не буду, очень муторная тема оказалась)  хотя если не перематывать, то проблем с внедрением статора от гироскутера никаких, и нужно 4 дня (в основном, найти токаря, найти время чтобы до него доехать  - отдать - дождаться -  забрать). Статор и магниты переставляются за час, ну и нужно подождать пока полимерезуется клей. 


 1     2   
potia75
Новичок
potia75
03 may 2019, 16:08
Posted: 03 may 2019, 16:08

Всех приветствую!

Имею самокат, очередной клон Сяоми. Похоже Кактус его звать ( вай фая нет, акуум слабый, разьем питания другой, верх с кнопкой включения другой).

Неделю сын покатался, сломал гнездо питания. Помимо этого при старте упала мощность и ,идёт вибрация переднего колеса. Эта вибрация как рокот идет с момента старта до момента набора нормальной скорости (по нормальной ровной поверхности), т.е. от 10 км/час. После набора скорости все ок и едет нормально. После остановки и повторном старте, снова вибрация.

Грешил на подшипник, один имел люфт и я его сменил.

При выключенном питании переднее колесо крутится чуть легче, чем при включенном.

При разборе мотор колеса, внутри все чисто, царапин нет, гари нет.

Подскажите, что и где искать? Куда делась мощь на старте и откуда рокот-вибрация?




potia75
Новичок
potia75
03 may 2019, 16:14
Posted: 03 may 2019, 16:14
Alberto
Участник
Rating: 12
Alberto
06 may 2019, 12:48
Posted: 06 may 2019, 12:48
Ответ пользователю
potia75 : 03 may 2019, 16:08
на это сообщение (развернуть)
Всех приветствую!Имею самокат, очередной клон Сяоми. Похоже Кактус его звать ( вай фая нет, акуум слабый,...

Всех приветствую!

Имею самокат, очередной клон Сяоми. Похоже Кактус его звать ( вай фая нет, акуум слабый, разьем питания другой, верх с кнопкой включения другой).

Неделю сын покатался, сломал гнездо питания. Помимо этого при старте упала мощность и ,идёт вибрация переднего колеса. Эта вибрация как рокот идет с момента старта до момента набора нормальной скорости (по нормальной ровной поверхности), т.е. от 10 км/час. После набора скорости все ок и едет нормально. После остановки и повторном старте, снова вибрация.

Грешил на подшипник, один имел люфт и я его сменил.

При выключенном питании переднее колесо крутится чуть легче, чем при включенном.

При разборе мотор колеса, внутри все чисто, царапин нет, гари нет.

Подскажите, что и где искать? Куда делась мощь на старте и откуда рокот-вибрация?



[quote="potia75"]Эта вибрация как рокот идет с момента старта до момента набора нормальной скорости[/quote]

сделаю предположение, что с колесом все ок, но у вас проблема с одной фазой в контроллере? это объясняет потерю мощности - потеряется как раз 1/3, вибрацию при наборе скорости - когда идет максимальная нагрузка. Плюс еще довод к этому то, что на выключенном колесо крутится свободнее. Видимо, включенный контроллер слегка шунтирует обмотку..

 1   
potia75
Новичок
potia75
06 may 2019, 18:00
Posted: 06 may 2019, 18:00
Ответ пользователю
Alberto : 06 may 2019, 12:48
на это сообщение (развернуть)
[цитата potia75] сделаю предположение, что с колесом все ок, но у вас проблема с одной фазой в контроллере? это...
[quote="potia75"]Эта вибрация как рокот идет с момента старта до момента набора нормальной скорости[/quote]

сделаю предположение, что с колесом все ок, но у вас проблема с одной фазой в контроллере? это объясняет потерю мощности - потеряется как раз 1/3, вибрацию при наборе скорости - когда идет максимальная нагрузка. Плюс еще довод к этому то, что на выключенном колесо крутится свободнее. Видимо, включенный контроллер слегка шунтирует обмотку..

А как проверить фазы? Их три на выходе из контроллера?

Alberto
Участник
Rating: 12
Alberto
06 may 2019, 21:32
Posted: 06 may 2019, 21:32
Ответ пользователю
potia75 : 06 may 2019, 18:00
на это сообщение (развернуть)
А как проверить фазы? Их три на выходе из контроллера?

А как проверить фазы? Их три на выходе из контроллера?

их три. опять же предположу, что лучше осцилографом смотреть, но наверное, можно вывесить колесо и вольтметром в режиме переменного тока сравнить показания между фазами, стараясь выдержать одну и ту же скорость. Сами по себе значения напряжения между фазами ничего не будут значить, но должны быть примерно одинаковые для всех трех вариантов для здорового двигателя. но вопрос, как удержать постоянную скорость между замерами. 

 1   
2wd
Новичок
Rating: 2
2wd
07 may 2019, 23:29
Posted: 07 may 2019, 23:29

На отключенном моторе замыкать фазы по 2 по очереди между собой и прокручивать рукой - если обмотки целые, будет одинаковое сопротивление с лёгкими рывками при любой комбинации из двух.


Далее, замкнув все 3 фазы разом прокрутите колесо, должно быть плавное сопротивление нарастающей при попытке увеличить скорость прокрутки. 


Крутя рукой можно и датчики холла проверить подав на красный и чёрный + и - 5В соотв. Заменяя напряжение между чёрными и 3 цветами проводами холла можно убедиться в том что каждый работает и исправен если меняется напряжение от 0 с чем-то до 3,5_4В. 


 1     2   
Alberto
Участник
Rating: 12
Alberto
08 may 2019, 10:45
Posted: 08 may 2019, 10:45

ну наконец нашлось немного времени замерить скорость на обновленном МК. Макс. скорость на 42 вольтовой батарее - 37 на ровной поверхности, и 39 под небольшой уклон. Страшновато, так как появился баг - при резком  торможении на скорости может отключиться рекупация (без сигналов, молча). После пары секунд все возращается в норму. Пришлось подтянуть задний тормоз, чтобы перераспределить тормозное усилие.


Вопрос,  в чем причина сброса рекупации. судя по скриншотам, перегрева вроде нет, овервольтжа нет, перегрузки по току тоже нет - на максималке потребление 15 ампер, на разгоне - 25А. Может, конечно, есть мгновенные броски напряжения/тока, которые контроллер не успевает передать через блютуз в приложение? 


 1   
nikola_tesla
Участник
Rating: 38
nikola_tesla
18 may 2019, 8:00
Posted: 18 may 2019, 8:00
Ответ пользователю
Alberto : 08 may 2019, 10:45
на это сообщение (развернуть)
ну наконец нашлось немного времени замерить скорость на обновленном МК. Макс. скорость на 42 вольтовой...

ну наконец нашлось немного времени замерить скорость на обновленном МК. Макс. скорость на 42 вольтовой батарее - 37 на ровной поверхности, и 39 под небольшой уклон. Страшновато, так как появился баг - при резком  торможении на скорости может отключиться рекупация (без сигналов, молча). После пары секунд все возращается в норму. Пришлось подтянуть задний тормоз, чтобы перераспределить тормозное усилие.


Вопрос,  в чем причина сброса рекупации. судя по скриншотам, перегрева вроде нет, овервольтжа нет, перегрузки по току тоже нет - на максималке потребление 15 ампер, на разгоне - 25А. Может, конечно, есть мгновенные броски напряжения/тока, которые контроллер не успевает передать через блютуз в приложение? 

Была похожая проблема. Только у меня полностью вырубался самокат. Проблема была в большом конденсаторе который стоит у штекера контроллера. Я его на провода посадил так как мешался, после этого начались все траблы. Проблему решил укорочением проводов и дополнительно мосфетам поставил такой же кондёр. 

Сейчас у меня самокат на 15S. На мосфеты поставил 80V 1000uf кондёр. Хотя и без него всё работало

nikola_tesla
Участник
Rating: 38
nikola_tesla
18 may 2019, 13:33
Posted: 18 may 2019, 13:33

Такой вопрос. Магниты клеятся как угодно или у них есть лицевая и обратная сторона?

Alberto
Участник
Rating: 12
Alberto
18 may 2019, 14:04
Posted: 18 may 2019, 14:04
Ответ пользователю
nikola_tesla : 18 may 2019, 8:00
на это сообщение (развернуть)
Была похожая проблема. Только у меня полностью вырубался самокат. Проблема была в большом конденсаторе...

Была похожая проблема. Только у меня полностью вырубался самокат. Проблема была в большом конденсаторе который стоит у штекера контроллера. Я его на провода посадил так как мешался, после этого начались все траблы. Проблему решил укорочением проводов и дополнительно мосфетам поставил такой же кондёр. 

Сейчас у меня самокат на 15S. На мосфеты поставил 80V 1000uf кондёр. Хотя и без него всё работало

Да, уже разобрался, у меня он жутко перегревался. Видимо, конденсатор перестает справляться с возросшей импульсной нагрузкой. Все пока времени нет заменить конденсатор

Alberto
Участник
Rating: 12
Alberto
18 may 2019, 14:07
Posted: 18 may 2019, 14:07
Ответ пользователю
nikola_tesla : 18 may 2019, 13:33
на это сообщение (развернуть)
Такой вопрос. Магниты клеятся как угодно или у них есть лицевая и обратная сторона?

Такой вопрос. Магниты клеятся как угодно или у них есть лицевая и обратная сторона?

В явном  виде отличий в сторонах нет, но они должны чередоваться направлением поля, через один 

Alberto
Участник
Rating: 12
Alberto
19 may 2019, 17:01
Posted: 19 may 2019, 17:01

похоже, проблема где то глубже.. греется что то еще -хотя общая тем-ра контроллера была 45 гр. макс. Удвоение емкости основного и добавление 3 дополнительных конденсаторов (общая емкость х3) проблему не решила, полчаса нормальной езды, и все.. Видимо, буду одну жилу из семи срезать на моторе...

Conejo
Форумчанин
МадридRating: 364
Conejo
19 may 2019, 18:22
Posted: 19 may 2019, 18:22
Ответ пользователю
Alberto : 19 may 2019, 17:01
на это сообщение (развернуть)
похоже, проблема где то глубже.. греется что то еще -хотя общая тем-ра контроллера была 45 гр. макс. Удвоение...

похоже, проблема где то глубже.. греется что то еще -хотя общая тем-ра контроллера была 45 гр. макс. Удвоение емкости основного и добавление 3 дополнительных конденсаторов (общая емкость х3) проблему не решила, полчаса нормальной езды, и все.. Видимо, буду одну жилу из семи срезать на моторе...

Почему жилу, а не программно? Результат будет одинаковый - ниже ток, но с отрезанной жилой это будет за счёт большего сопротивления мотора (а значит большего нагрева и в конечном итоге обогрева атмосферы от батареи), а программно - без потерь.

Alberto
Участник
Rating: 12
Alberto
19 may 2019, 23:49
Posted: 19 may 2019, 23:49
[quote="Conejo"]Почему жилу, а не программно?[/quote]

тут сработало больше чувство перфекционизма.. я сначала при перемотке намотал 6 жил, а когда увидел, что осталось еще место, добавил сверху еще одну.. уверен, что в принципе, должно быть все равно, что намотать сразу 7, но ощущение, что так неправильно, осталось)) особенно, на фоне этих проблем с перегревом кондесатора и контроллера.

ну плюс еще думается, что проблемой могло быть слишком низкое сопротивление обмотки. К тому же поставил прошивку от про версии, этой мощности очень даже достаточно, больше не хочу никаких доработок, хочу ездить до каршеринга и все. Посмотрим, помогло или нет..

Mike Vaghur
Новичок
Москва
Mike Vaghur
23 may 2019, 20:43
Posted: 23 may 2019, 20:43

Всем привет. Что-то после герметизации и перебортировки МК перестало крутится. В приложении вращая от руки показывает скорость 5-7 кмч. Может, конечно, что-то с выходом провода из оси — один раз при натягивании покрышки колесо соскочило и внешняя оболочка чуть задралась, но внутри провода выглядят целыми — они вроде достаточно толстые. Как можно прозвонить кабель не разбирая дофига всего? Ещё пытался вытащить статор, но вообще не получилось его выдавитьвытянуть.

ЗЫ: может для защиты стоит накрутить на выход провода подходящую пружину на будущее 

Alberto
Участник
Rating: 12
Alberto
25 may 2019, 15:33
Posted: 25 may 2019, 15:33
[quote="Alberto"] Посмотрим, помогло или нет.[/quote]

отключение 1 жилы практически помогло. Проблем после нескольких поездок небыло, но вот один раз словил этот глюк при продолжительной езде с ребенком, с постоянными разгонами и торможениями. Контроллер нагрелся до 39 градусов. Вопрос, с какой точки контроллера можно снять 5в для микровентилятора? 

Conejo
Форумчанин
МадридRating: 364
Conejo
25 may 2019, 19:31
Posted: 25 may 2019, 19:31
Ответ пользователю
Alberto : 25 may 2019, 15:33
на это сообщение (развернуть)
[цитата Alberto] отключение 1 жилы практически помогло. Проблем после нескольких поездок небыло, но вот один раз...
[quote="Alberto"] Посмотрим, помогло или нет.[/quote]

отключение 1 жилы практически помогло. Проблем после нескольких поездок небыло, но вот один раз словил этот глюк при продолжительной езде с ребенком, с постоянными разгонами и торможениями. Контроллер нагрелся до 39 градусов. Вопрос, с какой точки контроллера можно снять 5в для микровентилятора? 

Там есть тестовая точка, так и подписанная - 5V.

А по хорошему бы сначала с теплоотводом транзисторов помудрить - термопрокладку под них вместо каптона, прижим к ней нормальный, между корпусом контроллера и декой либо тоже прокладку, либо пастой нормально помазать (в старых экземплярах пара мазков для вида бывает) - отводить то есть куда, масса большая, только  условия создать.

Ну и в целом - 39 градусов для тех транзисторов - ничто, открываем напр. даташит на NCEP85T14 - рабочая температура - до +170, макс. долговременный ток при 100 градусах - 99А.

Alberto
Участник
Rating: 12
Alberto
25 may 2019, 20:34
Posted: 25 may 2019, 20:34
[quote="Conejo"]Ну и в целом - 39 градусов для тех транзисторов[/quote]

ок, спасибо, видимо, невнимательно посмотрел, поищу точку потщательнее.  А на счет проблем с контроллером -сам не ожидал, что такое случится, думал, что запас по нагрузке еще должен быть большой. Сами транзисторы, вроде и не греются, мне кажется, проблема начинается где то в обвязке. Раньше очень грелся конденсатор, сейчас после апдейта греется не так сильно, и глюки практически прошли, но видимо, что то еще нестабильно ведет себя в схеме... 

nikola_tesla
Участник
Rating: 38
nikola_tesla
03 june 2019, 11:04
Posted: 03 june 2019, 11:04

@M365 spain

На что клеил магниты?